Αναζήτηση σε δισδιάστατο πίνακα

Για την 5ήμερη εκδρομή της Γ Λυκείου ενός σχολείου, οι 60 μαθητές της, αποφάσισαν να διεξάγουν μια λαχειοφόρο αγορά, πουλώντας λαχνούς.
Κάθε μαθητής πούλησε από 30 λαχνούς. Σε έναν πίνακα ΑΡΙΘΜΟΙ[60, 30] καταγράφτηκαν οι αριθμοί από τους λαχνούς των 60 μαθητών και σε ένα πίνακα ΟΝΟΜΑ[60] τα ονόματα των 60 μαθητών.
Να γίνει αλγόριθμος, που με δεδομένο τον πίνακα ΑΡΙΘΜΟΙ και τον πίνακα ΟΝΟΜΑ, θα διαβάζει τον τυχερό αριθμό που κληρώθηκε και θα εμφανίζει ποιος μαθητής πούλησε τον τυχερό λαχνό.

Αλγόριθμος Λαχειοφόρος_αγορά
Δεδομένα //ΑΡΙΘΜΟΙ, ΟΝΟΜΑ//
 
Διάβασε αριθμός_κλήρωσης
 
! Θα αναζητήσουμε στον πίνακα ΑΡΙΘΜΟΙ. Ο πίνακας ωστόσο είναι διδιάστατος συνεπώς θα εφαρμόσουμε τη
! γνωστή μας σειριακή αναζήτηση, για κάθε γραμμή και στήλη του πίνακα ΑΡΙΘΜΟΙ
 
βρέθηκε <- ΨΕΥΔΗΣ
i <- 1
Όσο i <= 60  ΚΑΙ βρέθηκε = ΨΕΥΔΗΣ επανάλαβε
   j <- 1
   Όσο j <= 30 KAI βρέθηκε = ΨΕΥΔΗΣ επανάλαβε
      Αν ΑΡΙΘΜΟΙ[i,j] = αριθμός_κλήρωσης τότε
         βρέθηκε <- ΑΛΗΘΗΣ
         Εμφάνισε "Ο Αριθμός που κληρώθηκε ανήκει σε λαχνό που πουλήθηκε από τον μαθητή", ONOMA[i]
      Τέλος_αν
      j <- j + 1
   Τέλος_επανάληψης
   i <- i + 1
Τέλος_επανάληψης
 
Αν βρέθηκ = ΨΕΥΔΗΣ τότε
   Εμφάνισε “Ο αριθμός που κληρώθηκε δεν ανηκει σε κάποιο τυχερό, Τζακ ποτ!”
Τέλος_αν
 
Τέλος Λαχειοφόρος_αγορά

1 σχόλιο για το άρθρο “Αναζήτηση σε δισδιάστατο πίνακα

  • 04/04/2013 at 22:55
    Permalink

    το να μην ανήκει ο αριθμός σε κάποιο υχε΄ρο είναι αδύνατον καθώς απο την λαχειοφόρο τραβάμε μόνο τα έγκυρα οπότε θα υπάρχει στάνταρ

Αφήστε μια απάντηση

Η ηλ. διεύθυνσή σας δεν δημοσιεύεται. Τα υποχρεωτικά πεδία σημειώνονται με *