Διαγράμματα Ροής

Άσκηση 1
Να μετατραπεί ο ακόλουθος αλγόριθμος σε ισοδύναμο διάγραμμα ροής

Αλγόριθμος ΆσκησηΔΡ10
   x <- 1
   A <- 0
   Όσο Α < 100 επανάλαβε
      Β <- 0
      Αρχή_επανάληψης
         Β <- Β + x
         x <- x + 2
      Μέχρις_ότου x > 10
      A <- A + x
      Διάβασε x
   Τέλος_επανάληψης
   Εμφάνισε Α
Τέλος ΆσκησηΔΡ10

Λύση
Το «δύσκολο» κομμάτι της άσκησης είναι η εμφωλευμένη εντολή Αν. Ουσιαστικά δημιουργείται ένας ακόμη ρόμβος μέσα στον ήδη υπάρχοντα.
Διάγραμμα Ροής, άσκηση 1

Άσκηση 2
Να μετατραπεί ο ακόλουθος αλγόριθμος σε ισοδύναμο διάγραμμα ροής

Αλγόριθμος ΆσκησηΔΡ11
   x <- 1
   S <- 0
   Όσο x < 100 επανάλαβε
      S <- S + x
      Εμφάνισε S
      x <- x + 2
      y <- 10
      Όσο y > 0 επανάλαβε
         S <- S + y
         y <- y - 2 
      Τέλος_επανάληψης
   Τέλος_επανάληψης
   Εμφάνισε S
Τέλος ΆσκησηΔΡ11

Λύση
Διάγραμμα Ροής, Άσκηση 2

Άσκηση 3
Να μετατραπεί ο ακόλουθος αλγόριθμος σε ισοδύναμο διάγραμμα ροής

Αλγόριθμος ΆσκσησηΔΡ3
  Διάβασε x
  y <- 0
  Για i από 1 μέχρι 8 με_βήμα 2
     Εμφάνισε x
     x <- x + 1
     y <- y + x
  Τέλος_επανάληψης
  Εμφάνισε y
Τέλος ΆσκσησηΔΡ3

Λύση
Η εντολή Γιά κάνει αυτοματοποιημένα 2 πράξεις: Αρχικοποιεί την μεταβλητή που ελέγχει στην αρχή, και πριν το Τέλος_επανάληψης αυξάνει την μεταβλητή που ελέγχει κάτα την τιμή που ορίζει το βήμα της επανάληψης. Οι 2 αυτές πράξεις εννοούνται σε μια εντολή Για αλλά όχι και στο διάγραμμα ροής όπου θα πρέπει να φαίνονται.
Διάγραμμα Ροής, Άσκηση 3

15 σχόλια για το άρθρο “Διαγράμματα Ροής

Αφήστε μια απάντηση

Η ηλ. διεύθυνσή σας δεν δημοσιεύεται. Τα υποχρεωτικά πεδία σημειώνονται με *