Προβλήματα στη Δομή Επιλογής

Άσκηση 1
Να επιλύσετε την παρακάτω λογική συνθήκη αν οι μεταβλητές x, y και z έχους τις τιμές 3, 9 και -4 αντίστοιχα:

((x > y) ΚΑΙ (x + 4 < y - 6)) Η (ΟΧΙ(z - x > y^2) ΚΑΙ (z^2 < (x+y)^2))
((x > y) ΚΑΙ (x + 4 < y - 6)) Η (ΟΧΙ(z - x > y^2) ΚΑΙ (z^2 < (x+y)^2))
((3 > 9) ΚΑΙ (3 + 4 < 9 - 6)) Η (ΟΧΙ(-4 - 3 > 9^2) ΚΑΙ (-4^2 < (3+9)^2))
((3 > 9) ΚΑΙ (7 < 3)) Η (ΟΧΙ(-7 > 81) ΚΑΙ (16 < 144))
(ΨΕΥΔΗΣ ΚΑΙ ΨΕΥΔΗΣ) Η (ΟΧΙ(ΨΕΥΔΗΣ) ΚΑΙ ΑΛΗΘΗΣ)
(ΨΕΥΔΗΣ ΚΑΙ ΨΕΥΔΗΣ) Η (ΑΛΗΘΗΣ ΚΑΙ ΑΛΗΘΗΣ)
ΨΕΥΔΗΣ Η ΑΛΗΘΗΣ
ΑΛΗΘΗΣ

Άσκηση 2
Μία εταιρεία κινητής τηλεφωνίας παρέχει υπηρεσίες παροχής internet στους συνδρομητές της. Σύμφωνα με τα οικονομικά προγράμματα που έχει ανακοινώσει, προσφέρει 120MB δωρεάν με πάγιο 12€ και στην συνέχεια 0,65€ για κάθε επιπλέον MB που κατεβάζουν στο κινητό τους από το internet. Να γίνει αλγόριθμος που θα διαβάζει τον αριθμό των MB που κάποιος συνδρομητής κατέβασε στο κινητό του και να υπολογίζει και εκτυπώνει το ποσό που πρέπει να καταβάλει στην εταιρεία.

Αλγόριθμος Mobile_Internet
   ! Διάβασε τον αριθμό των MB που κάποιος χρήστης κατέβασε
   Διάβασε MB
   χρέωση <- 12
 
   ! Αν κατέβασες παραπάνω από 120MB πρέπει να χρεωθείς για την επιπλέον ποσότητα
   Αν MB > 120 τότε
      χρέωση <- χρέωση + (MB - 120) * 0,65
   Τέλος_αν
 
   Εκτύπωσε χρέωση
Τέλος Mobile_Internet

Άσκηση 3
Σε μία χώρα της Ε.Ε. οι κρατήσεις των ιδιωτικών υπαλλήλων υπολογίζονται βάσει της ηλικίας τους. Έτσι για τους 30 και άνω ετών η φορολόγηση είναι 22% του μισθού τους, ενώ για τους υπόλοιπους είναι 19%. Να γίνει πρόγραμμα που θα διαβάζει την ηλικία και τον μισθό ενός υπαλλήλου και θα υπολογίζει και θα εμφανίζει πόσες είναι οι κρατήσεις του.

ΠΡΟΓΡΑΜΜΑ κρατήσεις_εργαζόμενου
ΜΕΤΑΒΛΗΤΕΣ
  ΑΚΕΡΑΙΕΣ: ηλικία
  ΠΡΑΓΜΑΤΙΚΕΣ: μισθός, κρατήσεις
ΑΡΧΗ
  ΔΙΑΒΑΣΕ ηλικία, μισθός
  ΑΝ ηλικία >= 30 ΤΟΤΕ
    κρατήσεις <- μισθός * 22/ 100
  ΑΛΛΙΩΣ
    κρατήσεις <- μισθός * 19/ 100
  ΤΕΛΟΣ_ΑΝ
ΤΕΛΟΣ_ΠΡΟΓΡΑΜΜΑΤΟΣ κρατήσεις_εργαζόμενου

4 σχόλια για το άρθρο “Προβλήματα στη Δομή Επιλογής

  • 05/05/2014 at 14:06
    Permalink

    Γεια σας! Στην 3η άσκηση στα προβλήματα δομής επιλογής, στο κομμάτι απ’ το 1ο αλλιώς_αν ως και το τελευταίο αλλιώς_αν, θα έπρεπε, πιστεύω, να είναι του τύπου:
    Αλλιώς_αν τεμάχια > 50 και τεμάχια 100 και τεμάχια <= 200 τότε
    ..
    Ή μήπως δεν έχει σημασία; 🙂

  • 11/05/2014 at 11:59
    Permalink

    @Χάρης Κ. Δεν έχει σημασία. Για να εκτελεστεί αυτό το κομμάτι της αλλιώς_αν σημαίνει πως η προηγούμενη Αν, έχει αποτύχει. Άρα τα τεμάχια δεν είναι μικρότερα ή ίσα του 50, άρα είναι μεγαλύτερα!

  • 17/07/2016 at 19:43
    Permalink

    Άσκηση 3: Περιττές πράξεις με τη μεταβλητή «τεμάχια»

  • 17/07/2016 at 23:38
    Permalink

    @Γεώργιος Γ
    Fixed! Ευχαριστώ!

Αφήστε μια απάντηση

Η ηλ. διεύθυνση σας δεν δημοσιεύεται. Τα υποχρεωτικά πεδία σημειώνονται με *