Πίνακες Τιμών

Άσκηση 1
Να σχεδιάσετε τον πίνακα τιμών και τις τιμές που θα εμφανιστούν στην οθόνη μετά την εκτέλεση του παρακάτω αλγορίθμου:

Αλγόριθμος ΠίνακαςΤιμών1
x ← 10
y ← 95
Όσο x < 19 επανάλαβε
  x ← x + 2
  y ← y - x + 1
  Εμφάνισε x + y
Τέλος_επανάληψης
Τέλος ΠίνακαςΤιμών1
xyέξοδος
αρχικοποίηση1095
1η επανάληψη128496
2η επανάληψη147185
3η επανάληψη165672
4η επανάληψη183957
5η επανάληψη202040

Άσκηση 2
Να σχεδιάσετε τον πίνακα τιμών και τις τιμές που θα εμφανιστούν στην οθόνη μετά την εκτέλεση του παρακάτω αλγορίθμου:

Αλγόριθμος ΠίνακαςΤιμών2
x ← 13
y ← 21
Όσο x < 27 επανάλαβε
  y ← y + 2*x - 24
  z ← y div x
  Αν z mod 2 = 0 τότε
    x ← x + 2
  αλλιώς
    y ← y + 3
  Τέλος_αν
  Εμφάνισε x, y
  x ← x + 3
Τέλος_επανάληψης
Εμφάνισε x, y
Τέλος ΠίνακαςΤιμών2
xyzέξοδος
αρχικοποίηση1321
1η επανάληψη23
1
ψευδής αν26
13 26
16
2η επανάληψη34
2
αληθής αν18
18 34
21
3η επανάληψη52
2
αληθής αν23
23 52
26
4η επανάληψη80
3
ψευδής αν83
26 83
29
29 83

Άσκηση 3
Να σχεδιάσετε τον πίνακα τιμών και τις τιμές που θα εμφανιστούν στην οθόνη μετά την εκτέλεση του παρακάτω αλγορίθμου:

Αλγόριθμος ΠίνακαςΤιμών3
x ← 2
Για k από 1 μέχρι 9 με βήμα 3
  x ← x + k
  z ← 7
  Όσο z < x επανάλαβε
    z ← z + 2
    Εμφάνισε z
  Τέλος_επανάληψης
  Εμφάνισε x
Τέλος_επανάληψης
Τέλος ΠίνακαςΤιμών3
xkzέξοδος
αρχικοποίηση2
1η επανάληψη (Για)1
3
7
Όσο z < x (Ψευδής)
3
2η επανάληψη (Για)4
7
7
Όσο z < x (Ψευδής)
7
3η επανάληψη (Για)7
14
7
Όσο z < x (Αληθής)
9
9
Όσο z < x (Αληθής)
11
11
Όσο z < x (Αληθής)
13
13
Όσο z < x (Αληθής)
15
15
Όσο z < x (Ψευδής)
14
10

Αφήστε μια απάντηση

Η ηλ. διεύθυνσή σας δεν δημοσιεύεται. Τα υποχρεωτικά πεδία σημειώνονται με *